viernes, 28 de octubre de 2011

Actividad de Packet Tracer 4.4.1: Configuración básica del VTP




Objetivos de aprendizaje.

• Realizar las configuraciones básicas del switch.
• Configurar las interfaces Ethernet en las PC host.
• Configurar VTP y seguridad en los switches.


Introducción.

En esta actividad, realiza configuraciones básicas del switch, configura el VTP, los enlaces troncales, aprende acerca de los modos VTP, crea y distribuye información de la VLAN y asigna puertos a las VLAN. La red inicial se abre en un estado seguro con todos los puertos desactivados administrativamente.


Tarea 1: Realizar las configuraciones básicas del switch.

Configure los switches S1, S2 y S3 de acuerdo con las siguientes pautas y guarde todas las configuraciones:


Configure el nombre de host del switch como se indica en la topología.
  
Configurar los siguientes comandos en el switch 1.

Switch>enable
Switch#configure terminal

Enter configuration commands, one per line. End with CNTL/Z.--->se entra al modo de configuración global.
Switch(config)#hostname S1 

Configurar los siguientes comandos en el switch 2.
 
Switch>enable
Switch#configure terminal

Enter configuration commands, one per line. End with CNTL/Z.--->se entra al modo de configuración global.
Switch(config)#hostname S2

Configurar los siguientes comandos en el switch 3.

Switch>enable
Switch#configure terminal

Enter configuration commands, one per line. End with CNTL/Z.--->se entra al modo de configuración global.
Switch(config)#hostname S3
    Deshabilite la búsqueda DNS.

    Configurar los siguientes comandos en el switch 1.

    S1(config)#no ip domain-lookup

    Configurar los siguientes comandos en el switch 2.
       
    S2(config)#no ip domain-lookup
      
    Configurar los siguientes comandos en el switch 3.
       
    S3(config)#no ip domain-lookup

    Configure una contraseña class en el modo EXEC privilegiado encriptado.

    Configurar los siguientes comandos en el switch 1.
      
    S1(config)#enable secret class

    Configurar los siguientes comandos en el switch 2.
      
    S2(config)#enable secret class

    Configurar los siguientes comandos en el switch 3.
      
    S3(config)#enable secret class
     
    Configure la contraseña cisco para las conexiones de consola.


    Configurar los siguientes comandos en el switch 1.
     
    S1(config)#line console 0
    S1(config-line)#password cisco
    S1(config-line)#login


    Configurar los siguientes comandos en el switch 2.
     
    S2(config)#line console 0
    S2(config-line)#password cisco
    S2(config-line)#login


    Configurar los siguientes comandos en el switch 3.
     
    S3(config)#line console 0
    S3(config-line)#password cisco
    S3(config-line)#login

     
    Configure la contraseña cisco para las conexiones vty.


    Configurar los siguientes comandos en el switch 1.

    S1(config-line)#line vty 0 15
    S1(config-line)#password cisco
    S1(config-line)#login
    S1(config-line)#end
    %SYS-5-CONFIG_I: Configured from console by console--->se sale dell modo de configuración global.

    Configurar los siguientes comandos en el switch 2.

    S2(config-line)#line vty 0 15
    S2(config-line)#password cisco
    S2(config-line)#login
    S2(config-line)#end
    %SYS-5-CONFIG_I: Configured from console by console--->se sale dell modo de configuración global.

    Configurar los siguientes comandos en el switch 3.

    S3(config-line)#line vty 0 15
    S3(config-line)#password cisco
    S3(config-line)#login
    S3(config-line)#end
    %SYS-5-CONFIG_I: Configured from console by console--->se sale dell modo de configuración global.

    Nota:para copiar las configuraciones realizadas hasta el momento se tecleará el siguiente comando en los tres switches.

    S1#copy running-config startup-config
    Destination filename [startup-config]?
    Building configuration...
    [OK]

    Tarea 2: Configurar las interfaces Ethernet en las computadoras Host.

    Configure las interfaces Ethernet de PC1, PC2, PC3, PC4, PC5 y PC6 con las direcciones IP y los gateways predeterminados indicadas en la tabla de direccionamiento.

    Para esto desde Desktop, seleccione IP Configuration para configurar las interfaces Ethernet de los seis equipos PC con las direcciones IP y los gateways predeterminados que se indican en la tabla de direccionamiento, ubicada después del diagrama de topología.

     

    Tarea 3: Configurar VTP y seguridad en los switches.
    Paso 1: Habilite los puertos del usuario en S2 y S3.
     
    Configure los puertos de usuario en modo de acceso. Consulte el diagrama de topología para determinar qué puertos están conectados a dispositivos de usuario final.


    Configurar los siguientes comandos en el switch 2.

    S2(config)#interface fa0/6
    S2(config-if)#switchport mode access
    S2(config-if)#no shutdown
    S2(config-if)#interface fa0/11
    S2(config-if)#switchport mode access
    S2(config-if)#no shutdown
    S2(config-if)#interface fa0/18
    S2(config-if)#switchport mode access
    S2(config-if)#no shutdown


    Configurar los siguientes comandos en el switch 3.

    S3(config)#interface fa0/6
    S3(config-if)#switchport mode access
    S3(config-if)#no shutdown
    S3(config-if)#interface fa0/11
    S3(config-if)#switchport mode access
    S3(config-if)#no shutdown
    S3(config-if)#interface fa0/18
    S3(config-if)#switchport mode access
    S3(config-if)#no shutdown

     
    Paso 2: Verifique las configuraciones VTP actuales de los tres switches.
    Use el comando show vtp status para determinar el modo de funcionamiento VTP para los tres switches.


    S1#show vtp status





    S2#show vtp status

     S2#show vtp status

     NOTA: Se pude observar que los tres switches estan configurados en modo servidor y aun no tiene revisiones.
     
    Paso 3: Configure el modo operativo, el nombre del dominio y la contraseña VTP de los tres switches.

    Establezca el nombre de dominio VTP en Lab4 y la contraseña de VTP en cisco en los tres switches.

    Configure el S1 en modo servidor, con su correspondiente contraseña y dominio, con el siguiente comando:

    S1(config)#vtp mode server
    Device mode already VTP SERVER
    --->se entra al modo VTP SERVIDOR.
    S1(config)#vtp domain Lab4
    Changing VTP domain name from NULL to Lab4
    --->se establece el dominio
    S1(config)#vtp password cisco
    Setting device VLAN database password to cisco
    --->se estable la contraseña para la LAN que estara configurada por el VTP.
    S1(config)#end
    Configure el S2 en modo cliente, con su correspondiente contraseña y dominio, con el siguiente comando:
     
    S2(config)#vtp mode client
    Setting device to VTP CLIENT mode
    --->se entra al modo VTP CLIENTE
    S2(config)#vtp domain Lab4
    Changing VTP domain name from NULL to Lab4
    --->se establece el dominio
    S2(config)#vtp password cisco
    Setting device VLAN database password to cisco
    --->se estable la contraseña para la LAN que estara configurada por el VTP.
    S2(config)#end
    Configure el S3 en modo transparente, con su correspondiente contraseña y dominio, con el siguiente comando:

    S3(config)#vtp mode transparent
    Setting device to VTP TRANSPARENT mode.
    --->se entra al modo VTP transparente
    S3(config)#vtp domain Lab4
    Changing VTP domain name from NULL to Lab4
    --->se establece el dominio
    S3(config)#vtp password cisco
    Setting device VLAN database password to cisco
    --->se estable la contraseña para la LAN que estara configurada por el VTP.
    S3(config)#end

    Paso 4: Configure el enlace troncal y la VLAN nativa para los puertos del enlace troncal de los tres switches.

    En todos los switches, configure el enlace troncal y la VLAN nativa para las interfaces FastEthernet 0/1-5.

    Configurar los siguientes comandos en el switch 1.

    S1(config)#interface fa0/1-5
    S1(config-if)#switchport mode trunk
    S1(config-if)#switchport trunk native vlan 99
    S1(config-if)#no shutdown

    Configurar los siguientes comandos en el switch 2.
     
    S2(config)#interface 
    fa0/1-5
    S2(config-if)#switchport mode trunk
    S2(config-if)#switchport trunk native vlan 99
    S2(config-if)#no shutdown
    S2(config-if)#end
    Configurar los siguientes comandos en el switch 3.
     
    S3(config)#interface 
    fa0/1-5
    S3(config-if)#switchport mode trunk
    S3(config-if)#switchport trunk native vlan 99
    S3(config-if)#no shutdown
    S3(config-if)#end

    Paso 5: Configure la seguridad del puerto en los switches S2 y S3 de la capa de acceso.

    Configure los puertos fa0/6, fa0/11 y fa0/18 para que permitan únicamente un host y adquieran la dirección MAC del host de manera dinámica.
    Configurar los siguientes comandos en el switch 2.

    S2(config)#interface fa0/6
    S2(config-if)#switchport port-security
    S2(config-if)#switchport port-security maximum 1
    S2(config-if)#switchport port-security mac-address sticky
    S2(config-if)#interface fa0/11
    S2(config-if)#switchport port-security
    S2(config-if)#switchport port-security maximum 1
    S2(config-if)#switchport port-security mac-address sticky
    S2(config-if)#interface fa0/18
    S2(config-if)#switchport port-security
    S2(config-if)#switchport port-security maximum 1
    S2(config-if)#switchport port-security mac-address sticky
    S2(config-if)#end
    Configurar los siguientes comandos en el switch 3.

    S3(config)#interface fa0/6
    S3(config-if)#switchport port-security
    S3(config-if)#switchport port-security maximum 1
    S3(config-if)#switchport port-security mac-address sticky
    S3(config-if)#interface fa0/11
    S3(config-if)#switchport port-security
    S3(config-if)#switchport port-security maximum 1
    S3(config-if)#switchport port-security mac-address sticky
    S3(config-if)#interface fa0/18
    S3(config-if)#switchport port-security
    S3(config-if)#switchport port-security maximum 1
    S3(config-if)#switchport port-security mac-address sticky
    S3(config-if)#end

    Paso 6: Configure las VLAN en el servidor VTP.

    Se requieren cuatro VLAN en este laboratorio:
    • VLAN 99 (management)
    • VLAN 10 (faculty/staff)
    • VLAN 20 (students)
    • VLAN 30 (guest)

    Configúrelas en el servidor VTP.

    S1(config)#vlan 99
    S1(config-vlan)#name management
    S1(config-vlan)#exit
    S1(config)#vlan 10
    S1(config-vlan)#name faculty/staff
    S1(config-vlan)#exit
    S1(config)#vlan 20
    S1(config-vlan)#name students
    S1(config-vlan)#exit
    S1(config)#vlan 30
    S1(config-vlan)#name guest
    S1(config-vlan)#exit

    Paso 7: Verifique si las VLAN que se crearon en S1 se distribuyeron a S2 y S3.
     
    Use el comando show vlan brief en S2 y S3 para determinar si el servidor VTP ha enviado su configuración VLAN a todos los switches.
    NOTA: Se puede ver que ni el cliente ni el transparente tiene configuradas las VLAN. YA QUE EL CLIENTE Y EL SERVIDOR DEBEN ESTAR EN LA MISMA VERSION DEL VTP, POR SU PARTE EL TRANSPARENTE SE LE DEBEN DE CONFIGURAR MANUALMENTE.

    Configurar en el S1 la versión 2:

    S1(config)#vtp version 2

    Paso 8: Cree una nueva VLAN en S2 y S3.

    S2(config)#vlan 88
    %VTP VLAN configuration not allowed when device is in CLIENT mode--->No se puede crear ya que es un cliente.
    S3(config)#vlan 88
    S3(config-vlan)#name test
    NOTA: En S3 si se puede creear puesto que es un trasnparente. 
    Elimine la VLAN 88 de S3.

    S3(config)#no vlan 88

    Paso 9: Configure las VLAN manualmente.
     
    Configure en el switch S3 las cuatro VLAN que se identificaron.
     
    S3(config)#vlan 99
    S3(config-vlan)#name management
    S3(config-vlan)#exit
    S3(config)#vlan 10
    S3(config-vlan)#name faculty/staff
    S3(config-vlan)#exit
    S3(config)#vlan 20
    S3(config-vlan)#name students
    S3(config-vlan)#exit
    S3(config)#vlan 30
    S3(config-vlan)#name guest
    S3(config-vlan)#exit

    Paso 10: Configure la dirección de interfaz de administración en los tres switches.

    Configurar los siguientes comandos en el switch 1.

    S1(config)#interface vlan 99
    S1(config-if)#ip address 172.17.99.11 255.255.255.0
    S1(config-if)#no shutdown

    Configurar los siguientes comandos en el switch 2.

    S2(config)#interface vlan 99
    S2(config-if)#ip address 172.17.99.12 255.255.255.0
    S2(config-if)#no shutdown

    Configurar los siguientes comandos en el switch 3.
     
    S3(config)#interface vlan 99
    S3(config-if)#ip address 172.17.99.13 255.255.255.0
    S3(config-if)#no shutdown

    Verifique que todos los switches estén correctamente configurados haciendo ping entre ellos. Desde S1, haga ping en la interfaz de administración de S2 y S3. Desde S2, haga ping a la interfaz de administración en S3.

    Se puede observar en esta imagen la conectividad entre switches.

    Paso 11: Asigne puertos de switch a las VLAN.
     
    Consulte la tabla de asignación de puertos al comienzo de la actividad para asignar puertos a las VLAN.
     
    La asignación de puertos no se configura por medio de VTP. La asignación de puertos se debe configurar en cada switch manual o dinámicamente con un servidor VMPS. Sólo se muestran los comandos para S3, pero los switches S2 y S3 se deben configurar de manera similar. Cuando termine, guarde la configuración.

    Configurar los siguientes comandos en el switch 2.

    S2(config)#interface range fa0/6 – fa0/10
    S2(config-if-range)#switchport access vlan 30
    S2(config-if-range)#interface range fa0/11 – fa0/17
    S2(config-if-range)#switchport access vlan 10
    S2(config-if-range)#interface range fa0/18 – fa0/24
    S2(config-if-range)#switchport access vlan 20
    S2(config-if-range)#end
    S2#copy running-config startup-config
    Destination filename [startup-config]? [Intro]
    Building configuration...
    [OK]
     
    Configurar los siguientes comandos en el switch 3.

    S3(config)#interface range fa0/6 – fa0/10
    S3(config-if-range)#switchport access vlan 30
    S3(config-if-range)#interface range fa0/11 – fa0/17
    S3(config-if-range)#switchport access vlan 10
    S3(config-if-range)#interface range fa0/18 – fa0/24
    S3(config-if-range)#switchport access vlan 20
    S3(config-if-range)#end
    S3#copy running-config startup-config
    Destination filename [startup-config]? [Intro]
    Building configuration...
    [OK]

    NOTA:Para verificar que existe ping de PC A PC, solo se teclea la dirección de la PC  a la que se quiere llegar, dentro de una misma vlan en el switch. Si se quiere hacer ping a una PC que se encuentre en otra vlan, se cambiaran los puertos de manera fisica.




    1 comentario: